EveryPay deposits in Europe
Incident Report for Luno
Resolved
Deposits via EveryPay are available to iOS customers, please ensure you update to the latest version of the app.
Posted about 1 month ago. Feb 12, 2019 - 09:16 UTC
Identified
We've identified an issue affecting deposits via EveryPay in Europe for customers using the iOS app. If you'd like to make a deposit with EveryPay please do so via the website at luno.com.

Our team are working on resolving the issue.
Posted about 1 month ago. Feb 08, 2019 - 17:08 UTC