Slow bank withdrawals in South Africa
Incident Report for Luno
Resolved
All services have returned to normal.
Posted about 2 months ago. Jun 27, 2019 - 15:05 UTC
Identified
Due to technical issues experienced with our FNB banking partner, withdrawals will be delayed as we were unable to process them. Withdrawals should be processed with the next payment schedule when technical issues has been resolved.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted 2 months ago. Jun 26, 2019 - 14:38 UTC
This incident affected: Bank deposits and withdrawals (South Africa).