Delayed bank withdrawals in Malaysia
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted Dec 11, 2019 - 12:02 UTC
Identified
Withdrawals in Malaysia will not be processed on 11 December 2019 due to the public holiday, unfortunately banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on 12 December 2019.

Please view our full withdrawal schedule via the link below:

https://www.luno.com/help/articles/11000022934
Posted Dec 09, 2019 - 07:57 UTC