Delays in sending BCH (Bitcoin Cash)
Incident Report for Luno
Resolved
Sending Bitcoin Cash has returned to normal, thanks for everyone's patience.
Posted 5 months ago. Mar 28, 2018 - 06:29 UTC
Identified
We’re currently unable to process BCH (Bitcoin Cash) sends. We expect to have this technical issue resolved in the next 24 hours. Thank you for your patience. We will update you here once BCH sends are processed as per normal again.
Posted 5 months ago. Mar 26, 2018 - 16:06 UTC