Paystack deposits in Nigeria
Incident Report for Luno
Resolved
Paystack deposits are behaving as expected, however GTBank customers are currently not able to process deposits at this stage. We'll notify GTBank customers when this functionality returns.
Posted 9 months ago. Dec 11, 2018 - 07:07 SAST
Identified
We've identified the issue and are working closely with Paystack to see this resolved. The issue has been narrowed down to seemingly only affect customers depositing from GTBank.
Posted 10 months ago. Nov 28, 2018 - 10:40 SAST
Investigating
Our team are investigating an issue with Paystack deposits affecting some customers in Nigeria. Please make use of an alternative payment method by following the deposit screen.

Updates to follow soon.
Posted 10 months ago. Nov 27, 2018 - 15:00 SAST