Slow bank withdrawals in Nigeria
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted Jul 19, 2019 - 16:24 SAST
Update
We are continuing to investigate this issue.
Posted Jul 19, 2019 - 09:48 SAST
Investigating
There will be a slight delay with Nigerian bank withdrawals requested on 19 July 2019. This is a temporary incident which we hope to see resolved during the day. We will re-attempt to release the withdrawals during the next release, you can find the full schedule here - https://www.luno.com/help/en/articles/11000022934
Posted Jul 19, 2019 - 09:47 SAST
This incident affected: Bank deposits and withdrawals (Nigeria).