Slow Bitcoin Receives
Incident Report for Luno
Resolved
All Bitcoin receive transaction times have returned to normal.
Posted Jul 24, 2019 - 16:44 SAST
Investigating
We've identified a backlog of transactions on the Blockchain, this will mean that your Bitcoin receives may be slow. The cause for the backlog of transactions isn't known at this stage.

Unfortunately the confirmation time can vary based on the fee included in the transaction. Unconfirmed transactions can be monitored here https://blockchain.info/unconfirmed-transactions

Further updates to follow.
Posted Jul 24, 2019 - 11:43 SAST
This incident affected: Bitcoin sends and receives.