Slow Ethereum transactions
Incident Report for Luno
Resolved
Network congestion has cleared and transactions are now being processed and confirmed normally. We'll continue to monitor closely.
Posted Nov 22, 2020 - 19:09 UTC
Investigating
The Ethereum blockchain is under severe strain at the moment, causing some transactions to be slow and more expensive than normal. Luno adjusts fees based on network activity and do try to have transactions broadcast and confirmed as quickly as possible, however, there may still be some unexpected delays or transactions may be more expensive than normal.

We've noticed a small backlog forming for transactions that we send, this is something that is unfortunately out of our control. We're continuing to monitor transaction throughput closely and adjust send fees dynamically.

Some transactions received into customers Ethereum wallet may be slower if a fee below the recommended amount is used to broadcast the transaction.

We'll post an update to this status page when the transaction backlog eases.

Thanks for your patience.
Posted Nov 22, 2020 - 16:09 UTC