Slow bank withdrawals in Nigeria
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted 28 days ago. Mar 22, 2019 - 08:02 UTC
Monitoring
The majority of withdrawals have been processed, we are continuing to monitor withdrawals batches throughout the day.
Posted about 1 month ago. Mar 20, 2019 - 08:37 UTC
Identified
Due to an error with the bank some withdrawal batches have not yet been processed. This is a temporary incident which we hope to see resolved tomorrow.

Some Nigerian customers may see a delay with bank withdrawals requested on 19 March 2019. Our team are working hard to get these processed as soon as possible.

We will re-attempt to release the withdrawals during the next release, you can find the full schedule here - https://www.luno.com/help/en/articles/11000022934

Updates to follow.
Posted about 1 month ago. Mar 19, 2019 - 17:08 UTC