Stocks & ETFs unavailable for Thanksgiving weekend

Incident Report for Luno

Resolved

This has now been resolved.
Posted Dec 01, 2025 - 07:22 UTC

Monitoring

Reminder that Stocks and ETFs will be unavailable due to the US market closure over Thanksgiving weekend. Trading will resume when markets re-open on Monday.
Posted Nov 27, 2025 - 08:31 UTC