Slow bank withdrawals in South Africa
Incident Report for Luno
Resolved
All services have returned to normal.
Posted Jul 24, 2019 - 18:38 SAST
Investigating
Some bank withdrawals in South Africa have been delayed from an earlier release batch dated 23 July 2019. Withdrawals should be processed with the next payment schedule when technical issues has been resolved.

Our team are working on resolving the issue.

Updates to follow.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Jul 24, 2019 - 09:03 SAST
This incident affected: Bank deposits and withdrawals (South Africa).