Delayed bank withdrawals in Indonesia
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted 6 months ago. Feb 19, 2018 - 07:01 UTC
Identified
Withdrawals in Indonesia have been delayed due to the public holiday, unfortunately banks do not process withdrawals over weekends or public holidays.

Withdrawals requested will be processed on 19-02-2018.

Please view our full withdrawal schedule via the link below:

https://www.luno.com/help/en/articles/11000022934-how-long-until-my-withdrawal-is-processed
Posted 6 months ago. Feb 16, 2018 - 08:07 UTC