Delayed Sends and Receives for Cardano(ADA
Incident Report for
Luno
Resolved
The issue has been resolved, ADA Sends and Receives are now going through.
Thank you for your patience
Posted
Nov
24
,
2025
-
05:58
UTC
Monitoring
We have implemented the fix, Sends and Receives should be going through as normal. We will monitor for any more issues.
Thank you for your patience.
Posted
Nov
22
,
2025
-
08:53
UTC
Update
We are still seeing delays on ADA(Cardano) sends and receives
We are working with the third party provider as a priority. We thank you for your patience.
Posted
Nov
21
,
2025
-
18:11
UTC
Identified
We have identified that a third party issue is causing delays in Cardano(ADA) sends and receives.
Sending and receiving Cardano may take longer than usual.
Our team is currently working on this as a priority.
Posted
Nov
21
,
2025
-
14:39
UTC
×
Subscribe to Incident
Subscribe to updates for
Delayed Sends and Receives for Cardano(ADA
via . You'll receive .