Delayed bank withdrawals in Nigeria
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted about 1 month ago. Feb 05, 2019 - 06:09 UTC
Identified
There may be temporary delays with Nigerian bank withdrawals requested on 4 February 2019. We’re working on resolving this and expect to have full functionality returned soon.

We will attempt to release the withdrawals during the next release. You can find the full withdrawal schedule here: https://www.luno.com/help/articles/11000022934
Posted about 1 month ago. Feb 04, 2019 - 13:51 UTC
This incident affected: Bank deposits and withdrawals (Nigeria).