Slow bank withdrawals in Indonesia
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Oct 11, 2020 - 17:44 UTC
Update
This issue has been resolved and withdrawals are being processed according to schedule.

Thank you.
Posted Oct 11, 2020 - 17:44 UTC
Identified
There will be a slight delay with Indonesian withdrawals requested on 8th October. This is a temporary incident with our banking partner, which we hope to see resolved during the day. We will re-attempt to release the withdrawals during the next release, you can find the full schedule here - https://www.luno.com/help/en/articles/11000022934

Updates to follow.
Posted Oct 08, 2020 - 15:00 UTC