Delayed bank withdrawal in Indonesia
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted Aug 20, 2018 - 13:06 UTC
Identified
Withdrawals in Indonesia will not be processed on 17 August 2018 due to the public holiday, unfortunately banks do not process withdrawals over weekends or public holidays.

Withdrawals requested will be processed on 20 August 2018.

Please view our full withdrawal schedule via the link below:

https://www.luno.com/help/en/articles/11000022934-how-long-until-my-withdrawal-is-processed
Posted Aug 17, 2018 - 07:33 UTC