Issue has been resolved. Thank you for your patience.
Posted Nov 27, 2025 - 06:00 UTC
Identified
We are currently experiencing delays in payment processing on Luno Pay.
Some transactions are taking longer than usual to complete or reflect in customer accounts. We are working with our third party to fix the issue as a priority.