Slow Ethereum transactions
Incident Report for Luno
Resolved
Most ETH transaction times have returned to normal, we'll continue to monitor closely.
Posted Mar 23, 2020 - 06:35 UTC
Monitoring
Some ETH transactions are slower than normal, we're closely monitoring the queues.
Slow transactions are a side affect of congestion on the Etheruem Blockchain.
Posted Mar 20, 2020 - 10:33 UTC
Identified
Customers may experience slower than normal ETH transactions on the Ethereum Blockchain, this is due to fluctuating network fees.
The fees spike in price irregularly due to congestion on the Blockchain.

Further updates to follow.
Posted Mar 16, 2020 - 10:55 UTC