Account verification delays in Nigeria
Incident Report for Luno
Resolved
Our third party verification provider has resolved the underlying issue and account verifications are being processed as normal.

A huge thanks again for everyone's patience.
Posted Feb 05, 2021 - 09:39 UTC
Investigating
Customers in Nigeria waiting to be verified to Level 1 using their NIN number may experience some delays due. This is due to our third-party verification service seeing a degraded performance.

We're currently communicating with them to see this resolved as quickly as possible.

Please try to verify your account using your BVN number. Thanks for your patience.
Posted Feb 04, 2021 - 07:38 UTC