Delayed bank withdrawal in South Africa
Incident Report for Luno
Resolved
This incident has been resolved.
Posted 4 months ago. Aug 10, 2018 - 06:00 UTC
Identified
Withdrawals in South Africa will not be processed on 9 August 2018 due to the public holiday, unfortunately banks do not process withdrawals over weekends or public holidays.

Withdrawals requested will be processed on 10 August 2018.

Please view our full withdrawal schedule via the link below:

https://www.luno.com/help/en/articles/11000022934-how-long-until-my-withdrawal-is-processed
Posted 4 months ago. Aug 08, 2018 - 14:53 UTC