Penarikan tidak dapat diproses pada hari libur di Indonesia
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted 16 days ago. Apr 03, 2019 - 19:01 UTC
Investigating
Sehubungan dengan hari libur Isra Mi’raj pada Rabu 3 April 2019, penarikan Anda di Luno tidak dapat diproses. Kami akan memproses penarikan Anda di hari berikutnya
Posted 17 days ago. Apr 02, 2019 - 17:44 UTC
This incident affected: Bank deposits and withdrawals (Indonesia).