Delayed bank withdrawal in South Africa
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted 3 months ago. Dec 18, 2018 - 06:01 UTC
Identified
Withdrawals in South Africa will not be processed on 17 December 2018 due to the public holiday, unfortunately banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on 18 December 2018.

Please view our full withdrawal schedule via the link below:

https://www.luno.com/help/articles/11000022934
Posted 3 months ago. Dec 14, 2018 - 06:52 UTC