Slow deposits to Stanbic in Nigeria
Incident Report for Luno
Resolved
Deposit times to Stanbic have returned to normal.
Posted Feb 14, 2017 - 08:21 UTC
Investigating
Deposits sent to Stanbic are taking longer to reflect than normal. Our team are working on a fix.
Posted Jan 31, 2017 - 11:06 UTC