Unable to submit support tickets
Incident Report for Luno
Resolved
Our team have resolved the errors, support tickets can be created as normal.
Posted 17 days ago. Oct 01, 2018 - 11:33 UTC
Identified
We've identified an issue where customers are unable to submit tickets via the Help Centre (luno.com/help)
Our team are aware and are working on the issue.

Please use the app to submit a ticket via the Support Centre until we can resolve this.
Posted 17 days ago. Oct 01, 2018 - 09:28 UTC