GT Collections deposits in Nigeria
Incident Report for Luno
Resolved
Deposits processed via GT Collections should clear successfully.
Posted 2 months ago. Sep 05, 2018 - 14:27 UTC
Identified
We've identified an issue affecting some Nigerian customers making use of GT Collections. An error may occur when trying to process a deposit from GT Collections to your NGN Luno Wallet, please make use of PayU until we can resolve this with GT Bank.

Updates to follow shortly.
Posted 2 months ago. Sep 04, 2018 - 15:19 UTC