Delayed withdrawals during Ramadan in Indonesia
Incident Report for Luno
Resolved
This incident has been resolved.
Posted 2 months ago. Jun 19, 2018 - 07:26 UTC
Update
We are continuing to investigate this issue.
Posted 2 months ago. Jun 11, 2018 - 09:41 UTC
Investigating
All withdrawal requests submitted from Monday 11 June 2018 will be delayed while our bank is observing Ramadan. We will resume processing withdrawals from Tuesday 19 June 2018.

Deposits remain uanaffected so you can still add money as usual during this period.

Ramadan Kareem.
Posted 2 months ago. Jun 11, 2018 - 09:41 UTC
This incident affected: Bank deposits and withdrawals (Indonesia).