Slow Bitcoin Send and Receives
Incident Report for Luno
Resolved
Bitcoin transactions look to be speeding up again, delays should be minimal. We'll continue to monitor throughput closely.
Posted Jun 09, 2017 - 04:11 UTC
Update
For the past few weeks, there have been increased transaction delays on the Bitcoin network, something which affects all Bitcoin providers and users all around the world.

Please read through our blog for more details https://www.luno.com/blog/en/post/bitcoin-transaction-delays
Posted May 10, 2017 - 05:01 UTC
Identified
We've identified a backlog of transactions on the Blockchain, this will mean that your Bitcoin send and receives may be slow. The cause for the backlog of transactions isn't known at this stage.

Unfortunately the confirmation time can vary based on the fee included in the transaction. Unconfirmed transactions can be monitored here https://blockchain.info/unconfirmed-transactions

Further updates to follow.
Posted May 04, 2017 - 06:49 UTC