Slow bank withdrawals in Nigeria
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted 13 days ago. Apr 06, 2019 - 07:52 UTC
Investigating
Due to an error with the bank some withdrawal batches have not yet been processed. This is a temporary incident which we hope to see resolved tomorrow.

Some Nigerian customers may see a delay with bank withdrawals. Our team are working hard to get these processed as soon as possible.

We will re-attempt to release the withdrawals during the next release, you can find the full schedule here - https://www.luno.com/help/en/articles/11000022934
Posted 18 days ago. Apr 01, 2019 - 08:14 UTC
This incident affected: Bank deposits and withdrawals (Nigeria).