Scheduled Maintenance
Incident Report for Luno
Resolved
The scheduled maintenance has been completed.
Posted Nov 11, 2020 - 21:31 UTC
Investigating
We'll be doing routine maintenance at 9pm UTC on 11 November 2020, this will not last more than an hour.

During this time the Exchange, Instant Buy and Sell and wallet balances for all cryptocurrencies may be unavailable or inaccurate.

Updates will be posted throughout the maintenance window.

Thanks for your understanding.
Posted Nov 11, 2020 - 15:16 UTC