No withdrawals processed on public holidays in Nigeria
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted 4 months ago. Feb 23, 2019 - 07:02 UTC
Investigating
No bank withdrawals will be processed on Friday, 22 February 2019.
Withdrawals are processed each business day from Monday to Friday, excluding public holidays. You can find the withdrawal schedule here:
https://www.luno.com/help/en/articles/11000022934-how-long-until-my-withdrawal-is-processed
Posted 4 months ago. Feb 21, 2019 - 08:07 UTC
This incident affected: Bank deposits and withdrawals (Nigeria).