Bank withdrawals in Indonesia
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted 9 days ago. Jun 10, 2019 - 04:38 UTC
Investigating
Withdrawals won’t be processed on 30 May 2019 in Indonesia due to a public holiday. Withdrawals will resume on Friday 31 May. Due to another holiday on 1 June, Eid Al Fitr’, withdrawals will only be processed on 10 June 2019.

This is because banks do not process withdrawals on a public holiday. Deposits will remain unaffected during this time.

You can find the withdrawal schedule here: https://www.luno.com/help/articles/11000022934
Posted 21 days ago. May 29, 2019 - 12:39 UTC
This incident affected: Bank deposits and withdrawals (Indonesia).