Delayed bank withdrawal in Indonesia
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted 23 days ago. Nov 21, 2018 - 08:52 UTC
Identified
Withdrawals in Indonesia will not be processed on 20 November 2018 due to the public holiday, unfortunately banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on 21 November 2018.

Please view our full withdrawal schedule via the link below:

https://www.luno.com/help/articles/11000022934
Posted 25 days ago. Nov 19, 2018 - 06:28 UTC