Delayed Withdrawals Nigeria
Incident Report for Luno
Resolved
This issue has been resolved.

We appreciate your paitence in your regard.
Posted Jun 10, 2022 - 09:20 UTC
Identified
We are currently experiencing an issue which may be causing temporary delays with Nigerian bank withdrawals.
Posted Jun 09, 2022 - 17:44 UTC
This incident affected: Bank deposits and withdrawals (Nigeria).