Slow bank withdrawals in Nigeria
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted about 1 month ago. Jul 18, 2019 - 08:11 UTC
Update
Some withdrawals may still be delayed, we're working as quickly as possible to have these processed and sent to the bank. Apologies for the delays.
Posted about 1 month ago. Jul 17, 2019 - 09:44 UTC
Identified
There will be a slight delay with Nigerian bank withdrawals requested on 16 July 2019. This is a temporary incident which we hope to see resolved during the day. We will re-attempt to release the withdrawals during the next release, you can find the full schedule here - https://www.luno.com/help/en/articles/11000022934

Updates to follow.
Posted about 1 month ago. Jul 16, 2019 - 14:47 UTC