Increase in phishing/scam attempts
Incident Report for Luno
Resolved
We are actively continuing to monitor phishing activity, please remain vigilant and forward any phishing attempts to phishing@luno.com.
Posted 3 months ago. Jul 12, 2018 - 06:47 UTC
Monitoring
Many of our customers, and Bitcoin holders in general, continue to be targeted by phishing scams. Please remain vigilant when responding to mails and clicking on links.

Luno will never ask you to share login details or fill in an attachment. Please double check that mails sent from Luno are from @luno.com and that you’re browsing https://www.luno.com.

Our team is continuing to work with various parties to reduce phishing attempts.

Should you receive a mail that you suspect is a phishing attempt please forward the mail to phishing@luno.com.
Posted 5 months ago. May 25, 2018 - 09:14 UTC