Slow account verifications in Nigeria
Incident Report for Luno
Resolved
Our team has resolved the issue with our third party verification service. Verification times has returned to normal.
Posted 3 months ago. May 18, 2018 - 14:48 UTC
Identified
We've identified some delays where automated verifications are failing, this means that we will need to manually verify your account which may result in some delays.

Our team are aware of the issue and are working on a fix.
Posted 3 months ago. May 18, 2018 - 07:38 UTC