Slow bank withdrawals in Nigeria
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted 15 days ago. Oct 30, 2018 - 08:24 UTC
Update
Some withdrawals may still be delayed, our team are still working on a permanent fix.
If your withdrawal is delayed in any way please reach out to our team via https://www.luno.com/help/tickets/new
Posted 23 days ago. Oct 22, 2018 - 07:25 UTC
Monitoring
Slow bank withdrawals in Nigeria have been resolved from our end, however we may see some errors from the bank. We're working closely with the bank to see this resolved permanently, updates will be posted again soon.

If your withdrawal is delayed in any way please reach out to our team via https://www.luno.com/help/tickets/new
Posted 29 days ago. Oct 16, 2018 - 09:12 UTC
Identified
Our team have identified some slow withdrawals in Nigeria.
Some withdrawals requested on Monday 8 October have seemingly failed due to a technical error. We're working closely with the banks to see this resolved.

No other withdrawals are affected.
Posted about 1 month ago. Oct 12, 2018 - 11:46 UTC
This incident affected: Bank deposits and withdrawals (Nigeria).