Delayed bank withdrawals in Malaysia
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted 7 days ago. Nov 07, 2018 - 08:39 UTC
Identified
Withdrawals in Malaysia will not be processed on 6 November 2018 due to the public holiday, unfortunately banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on 7 November 2018.

Please view our full withdrawal schedule via the link below:

https://www.luno.com/help/articles/11000022934
Posted 9 days ago. Nov 05, 2018 - 07:28 UTC