Slow account verification
Incident Report for Luno
Resolved
Verification times have returned to normal.
Posted 4 months ago. Feb 14, 2019 - 09:27 UTC
Monitoring
We're continuing to monitor account verification times, a small backlog still remains for some customers in Europe.
Posted 4 months ago. Feb 14, 2019 - 05:48 UTC
Identified
We've identified the issue and are working through a small backlog of account verifications.
Posted 4 months ago. Feb 13, 2019 - 19:17 UTC
Investigating
Some customers may experience slower than normal account verifications for level 2 and 3.
We're doing some preliminary investigation and hope to see this resolved soon.

Our team will attend to account verifications as quickly as possible.
Posted 4 months ago. Feb 13, 2019 - 18:41 UTC