No withdrawals processed on public holiday in Nigeria
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted 3 months ago. May 30, 2018 - 07:26 UTC
Identified
We wish all our Nigerian customers a happy Democracy Day on Tuesday, 29 May 2018.
No bank withdrawals will be processed on this public holiday.
Withdrawals are processed each business day from Monday to Friday, excluding public holidays. You can find the withdrawal schedule here:
https://www.luno.com/help/en/articles/11000022934-how-long-until-my-withdrawal-is-processed
Posted 3 months ago. May 29, 2018 - 07:06 UTC