Slow bank withdrawals in Nigeria
Incident Report for Luno
Resolved
All pending withdrawals have been processed and should clear in customers bank accounts by tomorrow afternoon at the latest.
Posted 2 months ago. Sep 05, 2018 - 14:26 UTC
Identified
There will be a slight delay with Nigeria withdrawals requested on 4 September. This is a temporary incident which we hope to see resolved during the day. We will re-attempt to release the withdrawals during the next release, you can find the full schedule here - https://www.luno.com/help/en/articles/11000022931-how-long-until-my-deposit-shows-in-my-luno-wallet

Updates to follow.
Posted 2 months ago. Sep 05, 2018 - 09:44 UTC