Account verification delays in Nigeria
Incident Report for Luno
Resolved
Account verification times have returned to normal.
Posted about 2 months ago. Jan 28, 2019 - 04:28 UTC
Identified
Some customers may experience slower than normal verification times after having submitting documents.

Our team have already identified the issue and are working to see this resolved as soon as possible.

If you have submitted documents for account verification we will send you an email once this has been completed.
Posted about 2 months ago. Jan 25, 2019 - 14:09 UTC