Delayed Standard Bank withdrawals in South Africa
Incident Report for Luno
Resolved
This incident has been resolved.
Posted about 2 months ago. Feb 22, 2019 - 08:54 UTC
Investigating
Withdrawals to Standard bank accounts may be delayed as some withdrawals have had to be processed via our FNB account.
Our team are working with Standard Bank to resolve this.
Posted about 2 months ago. Feb 21, 2019 - 14:23 UTC
This incident affected: Bank deposits and withdrawals (South Africa).