No withdrawals processed on public holidays in Indonesia
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted 20 days ago. May 30, 2018 - 07:27 UTC
Identified
We wish all our Indonesian customers a happy Waisak Day on Tuesday, 29 May, and a blessed Pancasila Day on Friday, 1 June 2018.
No bank withdrawals will be processed on these public holidays.
Withdrawals are processed each business day from Monday to Friday, excluding public holidays. You can find the withdrawal schedule here: https://www.luno.com/help/en/articles/11000022934-how-long-until-my-withdrawal-is-processed
Posted 21 days ago. May 29, 2018 - 07:15 UTC