Slow bank withdrawals in Nigeria
Incident Report for Luno
Resolved
Withdrawals have resumed as per our withdrawal schedule.
Posted about 2 months ago. Dec 07, 2017 - 11:44 UTC
Identified
Our bank is experiencing general downtime and this is impacting on the processing of naira withdrawals. Withdrawals will automatically resume as soon as the technical difficulties experienced by the bank have been resolved.
Posted about 2 months ago. Dec 06, 2017 - 15:25 UTC