Slow bank withdrawals in Indonesia
Incident Report for Luno
Resolved
This incident has been resolved.
Posted 4 months ago. Feb 12, 2018 - 16:47 UTC
Identified
There will be a slight delay with Mandiri withdrawals requested on 12-02-2018. This is a temporary incident which we hope to see resolved during the day. We will re-attempt to release the withdrawals during the next release, you can find the full schedule here - https://www.luno.com/help/en/articles/11000022931-how-long-until-my-deposit-shows-in-my-luno-wallet

Updates to follow.
Posted 4 months ago. Feb 12, 2018 - 06:53 UTC