Slow bank withdrawals in Nigeria
Incident Report for Luno
Resolved
All withdrawals are being processed again as per normal.
Posted 7 months ago. Dec 20, 2017 - 08:43 UTC
Investigating
There has been a delay in the processing of some withdrawals today. All pending withdrawals will be processed by tomorrow, Wednesday, 20.12.2017. The money should reflect in our customers' bank accounts at the latest 48 hours after the withdrawal has been processed. All affected customers will receive a confirmation email. We apologize for the inconvenience caused.
Posted 7 months ago. Dec 19, 2017 - 15:55 UTC