No withdrawals processed on public holiday in Malaysia
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted about 2 months ago. Dec 04, 2017 - 07:13 UTC
Investigating
We wish all our Malaysian customers a happy Mawlid on Friday, 1 December 2017.
No bank withdrawals will be processed on this public holiday.
Withdrawals are processed each business day from Monday to Friday, excluding public holidays. You can find the withdrawal schedule here: https://www.luno.com/help/en/articles/11000022934-how-long-until-my-withdrawal-is-processed
Posted about 2 months ago. Nov 30, 2017 - 13:49 UTC