Slow Bitcoin Send and Receives
Incident Report for Luno
Resolved
The amount of unconfirmed transaction has decreased substantially, however fees still remain high to send on-chain transactions. We'll continue to monitor the situation.
Posted 2 months ago. Nov 17, 2017 - 14:07 UTC
Identified
We've identified a backlog of transactions on the Blockchain, this will mean that your Bitcoin send and receives may be slow. The cause for the backlog of transactions isn't known at this stage.

Unfortunately the confirmation time can vary based on the fee included in the transaction. Unconfirmed transactions can be monitored here https://blockchain.info/unconfirmed-transactions

Further updates to follow.
Posted 2 months ago. Nov 12, 2017 - 09:25 UTC