Slow Bitcoin sends
Incident Report for Luno
Resolved
Bitcoin sends have returned to normal.
Thanks for everyone's patience.
Posted about 1 month ago. Jan 16, 2018 - 18:39 UTC
Identified
We've identified an issue affecting some Bitcoin sends from Luno Bitcoin wallets to other Bitcoin addresses.
This may affect some customers, our team have already identified the issue and are working on a fix.

Updates to follow soon.
Posted about 1 month ago. Jan 16, 2018 - 14:18 UTC